EIGRPの不等コストロードバランシング

目的

不等コストロードバランシングの設定を実施し、負荷分散されていることを確認します。

接続構成

EIGRPの不等コストロードバランシング
緑色の線は、シリアル接続です。
RouterA:DTE ⇔ DCE:RouterB:DCE
青色の線は、イーサネット接続です。
コンフィグはこちら・・・Config

設定

RouterAのConfig(一部抜粋)

 

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.2.1 255.255.255.0
!
router eigrp 1
variance 6 ←サクセサのメトリックの6倍までをサクセサの対象とする。
network 192.168.1.0
network 192.168.2.0
auto-summary
!

 

RouterBのConfig(一部抜粋)

 

interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 192.168.1.2 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 192.168.2.2 255.255.255.0
clockrate 64000
no fair-queue
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
auto-summary
!

設定確認

上記のコンフィグでは、 『 variance 6 』 を追加していますが、
ここでは解説のために、 『 variance 6 』 の設定のみ、未設定として説明していきます。

 

まず、RouterAのルーティングテーブルを確認します。

 

RouterA#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

D 10.0.0.0/8 [90/409600] via 192.168.1.2, 00:00:01, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial0/0
RouterA#

 

10.1.1.1/24宛ての経路は自動集約されていることがわかります。
また、192.168.1.2の経路を使用することもわかります。

 

 

続いて、RouterAでトポロジーテーブルを確認します。
すべての経路情報を確認したいので、オプションに「all-links」をつけて下さい。

 

RouterA#sh ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(192.168.1.1)

 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

 

P 10.0.0.0/8, 1 successors, FD is 409600, serno 9
via 192.168.1.2 (409600/128256), FastEthernet0/0
via 192.168.2.2 (2297856/128256), Serial0/0
P 192.168.1.0/24, 1 successors, FD is 281600, serno 7
via Connected, FastEthernet0/0
via 192.168.2.2 (2195456/281600), Serial0/0
P 192.168.2.0/24, 1 successors, FD is 2169856, serno 5
via Connected, Serial0/0
via 192.168.1.2 (2195456/2169856), FastEthernet0/0
RouterA#

 

10.0.0.0/8の経路情報は2つあります。

  • 192.168.1.2を通るパターン
  • 192.168.2.2を通るパターン

 

FD(フィージブルディスタンス)の409600と2297856を比較します。
値の小さい方(409600)のルート(192.168.1.2)がサクセサとなります。

 

このルート(192.168.1.2)がルーティングテーブルに登録されます。

 

ただ、このままではロードバランシングされないので、下記の設定を追加します。

 

RouterA(config)#router eigrp 1
RouterA(config-router)#variance 6
RouterA(config-router)#

 

サクセサである192.168.1.2のメトリックは409600です。
もう1つの経路である192.168.1.2経由のメトリックは2297856です。

 

サクセサのメトリックの6倍までをサクセサの対象とすればロードバランスの対象にできます。

 

 

一度、ルーティングテーブルをクリアして、再度ルーティングテーブルを確認します。

 

RouterA#clear ip route *
RouterA#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

D 10.0.0.0/8 [90/409600] via 192.168.1.2, 00:00:01, FastEthernet0/0
[90/2297856] via 192.168.2.2, 00:00:01, Serial0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial0/0
RouterA#

 

最初にルーティングテーブルを確認した時には表示されていなかったルート
192.168.2.2が追加されています。

 

これは、10.0.0.0/8宛てのパケットが2つの経路を使って負荷分散されることを意味しています。

  • 192.168.1.2
  • 192.168.2.2

 

実際に負荷分散されるか確認しましょう。
10.1.1.1宛ての経路情報を確認します。

 

RouterA#sh ip route 10.1.1.1
Routing entry for 10.0.0.0/8
Known via "eigrp 1", distance 90, metric 409600, type internal
Redistributing via eigrp 1
Last update from 192.168.2.2 on Serial0/0, 00:07:27 ago
Routing Descriptor Blocks:
* 192.168.1.2, from 192.168.1.2, 00:07:27 ago, via Ethernet0/0
Route metric is 409600, traffic share count is 240
Total delay is 6000 microseconds, minimum bandwidth is 10000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
192.168.2.2, from 192.168.2.2, 00:07:27 ago, via Serial0/0
Route metric is 2297856, traffic share count is 43
Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

 

RouterA#

 

黄色のマーカー部分に着目します。
この値は、この経路でパケットを転送する値です。
記載されている値を転送し終えたら、次の経路でパケットを転送します。

 

つまり、192.168.1.2の経路で240パケットを送る、
次は、192.168.2.2の経路で43パケットを送る、
これを交互に繰り返します。

 

拡張Pingで240個のパケットを送ってみます。

 

RouterA#ping
Protocol [ip]:
Target IP address: 10.1.1.1
Repeat count [5]: 240
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 240, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (240/240), round-trip min/avg/max = 1/2/4 ms
RouterA#

 

10.1.1.1宛ての経路情報を確認します。

 

RouterA#sh ip route 10.1.1.1
Routing entry for 10.0.0.0/8
Known via "eigrp 1", distance 90, metric 409600, type internal
Redistributing via eigrp 1
Last update from 192.168.2.2 on Serial0/0, 00:03:50 ago
Routing Descriptor Blocks:
192.168.1.2, from 192.168.1.2, 00:03:50 ago, via FastEthernet0/0
Route metric is 409600, traffic share count is 240
Total delay is 6000 microseconds, minimum bandwidth is 10000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
* 192.168.2.2, from 192.168.2.2, 00:03:50 ago, via Serial0/0
Route metric is 2297856, traffic share count is 43
Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 254/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

 

RouterA#

 

「*」印が192.168.2.2経由の経路に切り替わりました。
このように経路が切り替わって負荷分散されていることが確認できます。