EIGRPの基本設定

目的

EIGRPの設定をして異なるセグメント間で通信できることを確認します。

接続構成

EIGRPの基本設定
緑色の線は、シリアル接続です。
RouterA:DTE ⇔ DCE:RouterB:DCE ⇔ RouterC:DTE
RouterA:DCE ⇔ DTE:RouterC
青色の線は、イーサネット接続です。
コンフィグはこちら・・・Config

設定

RouterAのConfig(一部抜粋)

 

interface Ethernet0/0
ip address 192.168.4.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 192.168.1.1 255.255.255.0
no fair-queue
!
interface Serial0/1
ip address 192.168.3.2 255.255.255.0
clockrate 64000
!
router eigrp 1 ←EIGRPをAS番号1で動作させる
network 192.168.1.0
network 192.168.3.0
network 192.168.4.0
auto-summary ←経路の自動集約
EIGRPは自動集約機能が有効なクラスレスルーティングプロトコルのため、
EIGRPを有効にした時点で auto-summary が自動的に設定されます。

!

 

RouterBのConfig(一部抜粋)

 

interface Ethernet0
no ip address
shutdown
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 64000
!
router eigrp 1 ←EIGRPをAS番号1で動作させる
network 192.168.1.0
network 192.168.2.0
auto-summary ←経路の自動集約
EIGRPは自動集約機能が有効なクラスレスルーティングプロトコルのため、
EIGRPを有効にした時点で auto-summary が自動的に設定されます。

!

 

RouterCのConfig(一部抜粋)

 

interface Ethernet0
ip address 192.168.5.1 255.255.255.0
!
interface Seri ip al0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
interface Serial1
ip address 192.168.3.1 255.255.255.0
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
router eigrp 1 ←EIGRPをAS番号1で動作させる
network 192.168.2.0
network 192.168.3.0
network 192.168.5.0
auto-summary ←経路の自動集約
EIGRPは自動集約機能が有効なクラスレスルーティングプロトコルのため、
EIGRPを有効にした時点で auto-summary が自動的に設定されます。

!

設定確認

最初に、RouterAで動作しているルーティングプロトコルを確認します。

 

RouterA#sh ip protocols
Routing Protocol is "eigrp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 1
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is in effect
Automatic address summarization:
192.168.4.0/24 for Serial0/1, Serial0/0
192.168.3.0/24 for Ethernet0/0, Serial0/0
192.168.1.0/24 for Ethernet0/0, Serial0/1
Maximum path: 4
Routing for Networks:
192.168.1.0
192.168.3.0
192.168.4.0
Routing Information Sources:
Gateway Distance Last Update
192.168.3.1 90 00:03:09
192.168.1.2 90 00:03:09
Distance: internal 90 external 170

 

RouterA#

 

eigrpが動作しており、AS番号が1のEIGRPが有効になっていることが確認できました。

 

続いて、RouterAのルーティングテーブルを確認します。

 

RouterA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.4.0/24 is directly connected, Ethernet0/0
D 192.168.5.0/24 [90/2195456] via 192.168.3.1, 00:25:10, Serial0/1
D 10.0.0.0/8 [90/2297856] via 192.168.3.1, 00:04:02, Serial0/1
C 192.168.1.0/24 is directly connected, Serial0/0
D 192.168.2.0/24 [90/2681856] via 192.168.3.1, 00:36:49, Serial0/1
[90/2681856] via 192.168.1.2, 00:36:49, Serial0/0
C 192.168.3.0/24 is directly connected, Serial0/1
RouterA#

 

EIGRPで学習したルートは、「D」、または「EX」で表示されます。

 

D・・・EIGRPの内部ルート。該当ルータが参加するEIGRPのAS内で生成されたルート。

 

EX・・・EIGRPの外部ルート。該当ルータが参加するEIGRPのAS外で生成されて、再配送によってAS内に投入されたルート。

 

ここで注目したい部分が、10.0.0.0/8 です。
IPは24ビットで設定しましたが、経路集約されて8ビットになっています。
これは、デフォルトで自動集約がオンになっているためです。
EIGRPの設定モードで、no auto-summaryコマンドを入力すると自動集約をオフにできます。

 

設定内容は下記の通り。
RouterC(config)#router eigrp 1
RouterC(config-router)#no auto-summary

 

sh ip routeコマンドで確認すると、経路集約されていないことが確認できます。

 

RouterA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.4.0/24 is directly connected, Ethernet0/0
D 192.168.5.0/24 [90/2195456] via 192.168.3.1, 00:00:06, Serial0/1
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2297856] via 192.168.3.1, 00:00:06, Serial0/1
C 192.168.1.0/24 is directly connected, Serial0/0
D 192.168.2.0/24 [90/2681856] via 192.168.1.2, 00:00:11, Serial0/0
[90/2681856] via 192.168.3.1, 00:00:11, Serial0/1
C 192.168.3.0/24 is directly connected, Serial0/1
RouterA#

 

 

ネイバーテーブルを見てみましょう。
show ip eigrp neighborsコマンドで、現在確立しているネイバーが確認できます。

RouterA#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.3.1 Se0/1 10 00:02:55 784 4704 0 24
1 192.168.1.2 Se0/0 11 00:44:43 29 200 0 16
RouterA#

 

トポロジーテーブルを見てみましょう。
show ip eigrp topologyコマンドで、ネイバーから受信したすべてのルート情報が確認できます。

RouterA#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.4.1)

 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

 

P 10.1.1.0/24, 1 successors, FD is 2297856
via 192.168.3.1 (2297856/128256), Serial0/1
P 192.168.1.0/24, 1 successors, FD is 2169856
via Connected, Serial0/0
P 192.168.2.0/24, 2 successors, FD is 2681856
via 192.168.3.1 (2681856/2169856), Serial0/1
via 192.168.1.2 (2681856/2169856), Serial0/0
P 192.168.3.0/24, 1 successors, FD is 2169856
via Connected, Serial0/1
P 192.168.4.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0
P 192.168.5.0/24, 1 successors, FD is 2195456
via 192.168.3.1 (2195456/281600), Serial0/1
RouterA#

それぞれの情報の意味は下記のとおりです。

  • P・・・Passive状態でルートが利用可能。
  • 10.1.1.0/24・・・この経路情報で扱っているネットワーク。
  • 1 successors・・・サクセサ(最適経路に到達するためのネクストホップ・ルーター)は1つ。
  • FD is 2297856・・・最適経路までの合計メトリック(フィージブル・ディスタンス)値は2297856。
  • via 192.168.3.1・・・ネクストホップ・ルーターのアドレス。
  • (2297856/128256)・・・前半の2297856はFD(フィージブル・ディスタンス)値。

    後半の128256はAD(アドバタイズドディスタンス)値。

  • Serial0・・・EIGRPパケットを受信したインタフェース。

 

10.1.1.0/24の経路情報に注目します。
10.1.1.0/24宛ての経路は、192.168.1.1と192.168.3.1の2つがありますが、
192.168.3.1をネクストホップに選んでいます。

 

これはFDが小さい方をサクセサとするためです。

 

ちなみに、show ip eigrp topologyコマンドはすべての経路情報が表示されません。
すべての経路情報を表示するには、先ほどのコマンドに、all-links をつけて、
show ip eigrp topology all-linksコマンドを実行して下さい。

 

赤字の部分がFDですが、この値を比較して値が小さい方をサクセサとしています。

RouterA#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(192.168.4.1)

 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

 

P 10.1.1.0/24, 1 successors, FD is 2297856, serno 25
via 192.168.3.1 (2297856/128256), Serial0/1
via 192.168.1.2 (2809856/2297856), Serial0/0
P 192.168.1.0/24, 1 successors, FD is 2169856, serno 13
via Connected, Serial0/0
P 192.168.2.0/24, 2 successors, FD is 2681856, serno 23
via 192.168.3.1 (2681856/2169856), Serial0/1
via 192.168.1.2 (2681856/2169856), Serial0/0
P 192.168.3.0/24, 1 successors, FD is 2169856, serno 4
via Connected, Serial0/1
P 192.168.4.0/24, 1 successors, FD is 281600, serno 2
via Connected, Ethernet0/0
P 192.168.5.0/24, 1 successors, FD is 2195456, serno 24
via 192.168.3.1 (2195456/281600), Serial0/1
via 192.168.1.2 (2707456/2195456), Serial0/0
RouterA#

 

 

では次にdebugコマンドでパケットのやり取りを見てみます。

RouterA#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
Jun 19 21:31:01.649: EIGRP: Sending HELLO on Ethernet0/0
Jun 19 21:31:01.649: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
RouterA#
Jun 19 21:31:03.211: EIGRP: Received HELLO on Serial0/0 nbr 192.168.1.2
Jun 19 21:31:03.215: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
Jun 19 21:31:03.588: EIGRP: Sending HELLO on Serial0/1
Jun 19 21:31:03.588: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
Jun 19 21:31:04.906: EIGRP: Received HELLO on Serial0/1 nbr 192.168.3.1
Jun 19 21:31:04.906: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
Jun 19 21:31:06.060: EIGRP: Sending HELLO on Serial0/0
Jun 19 21:31:06.060: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
Jun 19 21:31:06.633: EIGRP: Sending HELLO on Ethernet0/0
Jun 19 21:31:06.633: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
Jun 19 21:31:07.546: EIGRP: Received HELLO on Serial0/0 nbr 192.168.1.2
Jun 19 21:31:07.546: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
Jun 19 21:31:08.311: EIGRP: Sending HELLO on Serial0/1
Jun 19 21:31:08.311: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
Jun 19 21:31:09.321: EIGRP: Received HELLO on Serial0/1 nbr 192.168.3.1
Jun 19 21:31:09.321: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
Jun 19 21:31:10.487: EIGRP: Sending HELLO on Serial0/0
Jun 19 21:31:10.487: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
Jun 19 21:31:11.461: EIGRP: Sending HELLO on Ethernet0/0
Jun 19 21:31:11.461: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

 

パケットの送信間隔を見てみると,5秒間隔で送信していることがわかります。
Helloパケットを使ってネイバーを確立し、ルート情報を交換します。

 

このように、デバッグコマンドを利用すると、そのルータで送受信するトラフィックの情報をリアルタイムに確認することができます。ただ、デバッグを実行するとルータに負荷がかかるので、トラブルシューティングなど必要な時のみ使用して下さい。

動作テスト1

EIGRPの基本設定

 

PC1とPC2が通信できることを確認します。
PC1からPC2にPingを打ちます。
下記の通り応答があれば疎通確認OKです。

 

C:\>ping 192.168.5.100

 

192.168.5.100 に ping を送信しています 32 バイトのデータ:
192.168.5.100 からの応答: バイト数 =32 時間 <1ms TTL=128
192.168.5.100 からの応答: バイト数 =32 時間 <1ms TTL=128
192.168.5.100 からの応答: バイト数 =32 時間 <1ms TTL=128
192.168.5.100 からの応答: バイト数 =32 時間 <1ms TTL=128

 

192.168.5.100 の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
最小 = 0ms、最大 = 0ms、平均 = 0ms

 

C:\>

 

次にPC2からPC1にPingを打ちます。こちらも疎通確認OKです。

 

C:\>ping 192.168.1.100

 

192.168.1.100 に ping を送信しています 32 バイトのデータ:
192.168.1.100 からの応答: バイト数 =32 時間 <1ms TTL=128
192.168.1.100 からの応答: バイト数 =32 時間 <1ms TTL=128
192.168.1.100 からの応答: バイト数 =32 時間 <1ms TTL=128
192.168.1.100 からの応答: バイト数 =32 時間 <1ms TTL=128

 

192.168.1.100 の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
最小 = 0ms、最大 = 0ms、平均 = 0ms

 

C:\>

動作テスト2

EIGRPの基本設定

 

PC1とPC2が通信する場合、経路が2つあります。

 

パターン1: RouterA → RouterB → RouterC
パターン2: RouterA → RouterC

 

EIGRPを有効にすると、パターン2の経路が有効になります。

 

ここで、擬似障害(RouterCのS1インターフェースをダウン)を発生させて経路が切り替わるか確認します。
また、復旧(RouterCのS1インターフェースをアップ)した場合、経路が戻るか確認します。

 

障害前のルーティングテーブルの内容です。
192.168.5.0/24宛ての経路がパターン2になっていることが確認できます。

RouterA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.4.0/24 is directly connected, Ethernet0/0
D 192.168.5.0/24 [90/2195456] via 192.168.3.1, 00:21:32, Serial0/1
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2297856] via 192.168.3.1, 00:21:32, Serial0/1
C 192.168.1.0/24 is directly connected, Serial0/0
D 192.168.2.0/24 [90/2681856] via 192.168.3.1, 00:21:32, Serial0/1
[90/2681856] via 192.168.1.2, 00:21:32, Serial0/0
C 192.168.3.0/24 is directly connected, Serial0/1
RouterA#

 

障害前のトポロジーテーブルの内容です。
192.168.5.0/24宛ての経路が2つあることが確認できます。

RouterA#sh ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(192.168.4.1)

 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

 

P 10.1.1.0/24, 1 successors, FD is 2297856, serno 6
via 192.168.3.1 (2297856/128256), Serial0/1
via 192.168.1.2 (2809856/2297856), Serial0/0
P 192.168.1.0/24, 1 successors, FD is 2169856, serno 1
via Connected, Serial0/0
P 192.168.2.0/24, 2 successors, FD is 2681856, serno 7
via 192.168.1.2 (2681856/2169856), Serial0/0
via 192.168.3.1 (2681856/2169856), Serial0/1
P 192.168.3.0/24, 1 successors, FD is 2169856, serno 2
via Connected, Serial0/1
P 192.168.4.0/24, 1 successors, FD is 281600, serno 9
via Connected, Ethernet0/0
P 192.168.5.0/24, 1 successors, FD is 2195456, serno 5
via 192.168.3.1 (2195456/281600), Serial0/1
via 192.168.1.2 (2707456/2195456), Serial0/0
RouterA#

 

 

RouterCで擬似障害を発生させます。(S1をダウンさせます)

RouterC(config-if)#int s1
RouterC(config-if)#shut

 

 

 

ルーティングテーブルを確認します。
経路が切り替わったことが確認できます。
192.168.3.1から192.168.1.2になっています。

RouterA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.4.0/24 is directly connected, Ethernet0/0
D 192.168.5.0/24 [90/2707456] via 192.168.1.2, 00:00:35, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2809856] via 192.168.1.2, 00:00:35, Serial0/0
C 192.168.1.0/24 is directly connected, Serial0/0
D 192.168.2.0/24 [90/2681856] via 192.168.1.2, 00:00:35, Serial0/0
RouterA#

 

トポロジーテーブルを確認します。
192.168.5.0/24の経路が1つのみになりました。

RouterA#sh ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(192.168.4.1)

 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

 

P 10.1.1.0/24, 1 successors, FD is 2809856, serno 22
via 192.168.1.2 (2809856/2297856), Serial0/0
P 192.168.1.0/24, 1 successors, FD is 2169856, serno 1
via Connected, Serial0/0
P 192.168.2.0/24, 1 successors, FD is 2681856, serno 21
via 192.168.1.2 (2681856/2169856), Serial0/0
P 192.168.4.0/24, 1 successors, FD is 281600, serno 9
via Connected, Ethernet0/0
P 192.168.5.0/24, 1 successors, FD is 2707456, serno 23
via 192.168.1.2 (2707456/2195456), Serial0/0
RouterA#

 

 

RouterCで擬似障害を復旧させます。(S1をアップさせます)

RouterC(config-if)#no shut

 

ルーティングテーブルを確認します。
192.168.5.0/24宛ての経路が192.168.3.1経由に戻りました。

RouterA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.4.0/24 is directly connected, Ethernet0/0
D 192.168.5.0/24 [90/2195456] via 192.168.3.1, 00:00:14, Serial0/1
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2297856] via 192.168.3.1, 00:00:14, Serial0/1
C 192.168.1.0/24 is directly connected, Serial0/0
D 192.168.2.0/24 [90/2681856] via 192.168.1.2, 00:00:14, Serial0/0
[90/2681856] via 192.168.3.1, 00:00:14, Serial0/1
C 192.168.3.0/24 is directly connected, Serial0/1
RouterA#

 

トポロジーテーブルを確認します。
192.168.5.0/24宛ての経路が2つに戻りました。

RouterA#sh ip eigrp topology all-links
IP-EIGRP Topology Table for AS(1)/ID(192.168.4.1)

 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

 

P 10.1.1.0/24, 1 successors, FD is 2297856, serno 26
via 192.168.3.1 (2297856/128256), Serial0/1
via 192.168.1.2 (2809856/2297856), Serial0/0
P 192.168.1.0/24, 1 successors, FD is 2169856, serno 1
via Connected, Serial0/0
P 192.168.2.0/24, 2 successors, FD is 2681856, serno 27
via 192.168.3.1 (2681856/2169856), Serial0/1
via 192.168.1.2 (2681856/2169856), Serial0/0
P 192.168.3.0/24, 1 successors, FD is 2169856, serno 24
via Connected, Serial0/1
P 192.168.4.0/24, 1 successors, FD is 281600, serno 9
via Connected, Ethernet0/0
P 192.168.5.0/24, 1 successors, FD is 2195456, serno 25
via 192.168.3.1 (2195456/281600), Serial0/1
via 192.168.1.2 (2707456/2195456), Serial0/0
RouterA#

 

【参考情報】
PC1からPC2にPingを打ち続けていましたが、
インターフェースをダウンさせて経路が切り替わった時、
2パケットだけ欠けました。

 

インターフェースをアップさせて復旧させた時は、パケットの欠けはありませんでした。