EIGRPの基本設定(Config)

RouterAのconfig

RouterA#sh run
Building configuration...

 

Current configuration : 1163 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$LP78$rt7E.qWVg8TMA1ZJ7bF4o/
!
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
interface Ethernet0/0
ip address 192.168.4.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 192.168.1.1 255.255.255.0
no fair-queue
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
!
interface Serial0/1
ip address 192.168.3.2 255.255.255.0
clockrate 64000
!
interface BRI1/0
no ip address
shutdown
!
interface BRI1/1
no ip address
shutdown
!
interface BRI1/2
no ip address
shutdown
!
interface BRI1/3
no ip address
shutdown
!
interface BRI1/4
no ip address
shutdown
!
interface BRI1/5
no ip address
shutdown
!
interface BRI1/6
no ip address
shutdown
!
interface BRI1/7
no ip address
shutdown
!
router eigrp 1
network 192.168.1.0
network 192.168.3.0
network 192.168.4.0
auto-summary
!
ip http server
ip classless
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

 

RouterA#

RouterBのconfig

RouterB#sh run
Building configuration...

 

Current configuration : 675 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
enable secret 5 $1$kTH0$WT.e4z.UAJk5v7KRuqV8S.
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.168.1.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface Serial1
ip address 192.168.2.1 255.255.255.0
clockrate 64000
!
router eigrp 1
network 192.168.1.0
network 192.168.2.0
auto-summary
!
ip classless
ip http server
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
end

 

RouterB#

RouterCのconfig

RouterC#sh run
Building configuration...

 

Current configuration : 1069 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
logging rate-limit console 10 except errors
enable secret 5 $1$a57M$snn57A062wSbSZxtbJ6GP.
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.5.1 255.255.255.0
no keepalive
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no fair-queue
!
interface Serial1
ip address 192.168.3.1 255.255.255.0
!
interface BRI0
no ip address
shutdown
isdn x25 static-tei 0
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
!
router eigrp 1
network 10.0.0.0
network 192.168.2.0
network 192.168.3.0
network 192.168.5.0
auto-summary
no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
login
!
end

 

RouterC#